分类 技术经验 下的文章

appwiz.cpl 卸载安装程序
bthprops.cpl 蓝牙和其他设备
desk.cpl 屏幕
Firewall.cpl 防火墙
hdwwiz.cpl 设备管理器
igfxCPL.cpl 核显控制面板
inetcpl.cpl internet属性
intl.cpl 区域管理
irprops.cpl 红外线相关的功能
joy.cpl 游戏控制器
main.cpl 定点装置属性
mmsys.cpl 声音
ncpa.cpl 网络链接
powercfg.cpl 电源选项
RTSnMg64.cpl 音频管理器
sysdm.cpl 系统属性
TabletPC.cpl 笔和触控
telephon.cpl 电话调制解调器
timedate.cpl 时间日期
wscui.cpl 安全维护

自己写的版本

<?php
$lang = substr($_SERVER['HTTP_ACCEPT_LANGUAGE'], 0, 4); //只取前4位,这样只判断最优先的语言。如果取前5位,可能出现en,zh的情况,影响判断。
if (preg_match("/zh-c/i", $lang))
header('Location: https://zh.aaa.bbb');
else if (preg_match("/zh/i", $lang))
header('Location: https://zh.aaa.bbb');
else if (preg_match("/en/i", $lang))
header('Location: https://en.aaa.bbb');
else if (preg_match("/de/i", $lang))
header('Location: https://de.aaa.bbb');
else header('Location: https://www.aaa.bbb/');
?>

GPT版本的

<?php
$lang = substr($_SERVER['HTTP_ACCEPT_LANGUAGE'], 0, 2); // 只取前两位,更准确地判断语言

$redirects = [

'zh' => 'https://aaa.bbb.ccc',
'en' => 'https://ccc.aaa.bbb/',
'de' => 'https://bbb.aaa.ccc',

];

$defaultRedirect = 'https://ccc.aaa.bbb/';

if (array_key_exists($lang, $redirects)) {

header('Location: ' . $redirects[$lang]);

} else {

header('Location: ' . $defaultRedirect);

}
?>

在GitHub项目用的是
https://github.com/zxb1655/weipyq

树莓派自带的yarn版本超低的运行不起来须完成如下操作后运行或者直接apt-get install yarnpkg 然后后面命令改成yarnpkg
1.安装nodejs

sudo apt-get install nodejs

2.更改源文件

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list

3.安装yarn

sudo apt update && sudo apt install yarn

4.yarn安装依赖

cd weipyq && yarn

5.运行项目

yarn dev:h5

6.打包项目

yarn build:h5